Author Topic: Raknet versions can't connect?  (Read 1035 times)

BlackMoon

  • Not-a-newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Raknet versions can't connect?
« on: February 09, 2015, 05:02:39 PM »
Hi, Was having problems building raknet for X64 so I redownloaded it and my problem went away. (error was 'LINK : fatal error LNK1104: cannot open file './../../Source/cat/lib/cat/big_x64.lib' )

Problem is now I can't seem to connect with clients built with the older raknet. No connection attempt is seen on the receiving end, even when I rebuilt the 32bit version that worked before.

I can't tell if raknet is still being worked on or not..

<edit>

Well I found that I needed to define
#define LIBCAT_SECURITY 1
to use the security thing I was using... But now the x64 build is complaining about not being able to open that big_x64.lib file.

Fixed it by removing the stupidly long path from BigRTL.cpp's usage of big_x64.lib and just putting the big_x64.lib in a standard lib path for my project.
« Last Edit: February 09, 2015, 05:42:27 PM by BlackMoon »