Author Topic: Issues building AutopatcherServer with cmake  (Read 19361 times)

Thomar

  • Not-a-newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Issues building AutopatcherServer with cmake
« on: October 27, 2012, 12:24:41 AM »
I'm trying to build the AutopatcherServer on a 64-bit Ubuntu 12.04 machine.

I've run cmake CMakeLists.txt while in RakNet/Source. I've also run it under RakNet/Samples/AutopatcherServer/CMakeLists.txt. However, when I go to RakNet/Samples/AutopatcherServer/ and run make I get this set of errors:

/home/web/dev/RakNet/Samples/AutopatcherServer/AutopatcherServerTest.cpp:4:19: fatal error: Kbhit.h: No such file or directory
compilation terminated.
make[2]: *** [CMakeFiles/AutopatcherServer_PostgreSQL.dir/AutopatcherServerTest.cpp.o] Error 1
make[1]: *** [CMakeFiles/AutopatcherServer_PostgreSQL.dir/all] Error 2
make: *** [all] Error 2

I understand that Kbhit.h is in RakNet/Source, but I don't understand how to run it. Any pointers?

Thomar

  • Not-a-newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: Issues building AutopatcherServer with cmake
« Reply #1 on: October 27, 2012, 03:33:11 PM »
Looking around, it seems like I'm not the only one with these kinds of problems. Has anyone been able to get RakNet to build on Linux? Is there a guide to getting RakNet to work on Linux? The readme gives some hints, but maybe I'm just not any good with g++ and cmake.

Rak'kar

  • Administrator
  • Hero Member
  • *****
  • Posts: 6895
  • Karma: 291
    • View Profile
    • RakNet
Re: Issues building AutopatcherServer with cmake
« Reply #2 on: October 28, 2012, 12:00:16 PM »
See readme.txt in the root directory. It has the command to build the autopatcher on Linux

ArthurTent

  • Not-a-newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: Issues building AutopatcherServer with cmake
« Reply #3 on: October 01, 2014, 07:57:02 AM »
Code: [Select]
../Samples/AutopatcherServer/AutopatcherServerTest.cpp:31:24: error: ‘MAX_PATH’ was not declared in this scopeWhen I define MAX_PATH, which shouldn't be necessary, since it should be a win32 limitation, I receive the exact same error as stoopdapoop here
http://www.jenkinssoftware.com/forum/index.php?topic=5291.0

I can build the raknet lib, I can build ALL other Samples... but not the Autopatcher Sample :(